Toolbars

The Toolbar is designed to facilitate the project management, the individual object control, as well as the object ordering and alignment:

The New, Open, and Save buttons correspond to the relevant commands in the File Menu. The Cut, Copy, Paste, and Delete buttons correspond to the relevant commands in the Edit Menu.

 Paste as Copy/ In Slide will create a new instance of the object that is copied in the clipboard. Unlike the simple Paste that creates a new object, Paste as Copy does not create objects. All changes applied to the originally copied object will be applied to all its instances.

The Select Display device  button opens the list of available hardware drivers, from which you can select the one to work with. See also the corresponding section in the Project Menu description.

TIP (!) If you want to change the driver before its initialization, hold down <Ctrl + Shift> during X-Pert Graphics startup to open the Driver select dialog.

 The Zoom spin-box allows resizing the work area, so you could see the whole project at a glance. It is very useful for viewing HD projects.

 This button opens the Data Source Manager window. It contains all supported data providing plug-ins. You can use them to “translate” different types of data and display the information they contain in some of the X-Pert Graphics objects. Please, check the Data Source Manager section further below.

 This button opens the Task Manager window. Please, check the Task Manager description in the related section further below.

When the Output aspect ratio is changed, X-Pert Graphics will automatically change the size of the objects according to the selected aspect. All of the aspect changes concerning one particular project are listed as presets in the Display resolutions dialog. To open it, press the display resolution  button. A dialog will appear. It provides possibilities for fast switching between the different presets. Pressing the  button or double-clicking one of the rows will initiate an aspect change. To delete a preset, use the  button.

The External aspect control  button is pressed by default. It is intended for automated switching of the aspect ratio according to an external source. Such a source can be WSS present in the incoming video, for example.

The As-run log ON/OFF  button allows you to enable/disable the X-Pert Graphics  As-Run Log application. The As-Run Log is configured in Project menu -> Options -> As-Run Log.

The Objects list button  shows a window with a list of all objects, available in the current X-Pert Graphics project.

The Properties buttons  are object-related. They allow for viewing or changing the properties of the currently selected object.

There are two types of properties: Standard Properties, that provide the standard object options, and Property Tools, which provide an additional set of properties. The Property Tools are active only for texts, rolls, and crawls.

IMPORTANT: The properties can be interactively changed at any moment, even when the object is running on-air.

The Play, Pause, Stop, and Toggle Play/Stop buttons control the play status of any particular object. They correspond to the relevant commands in the Object Menu.

The Group and Ungroup buttons  are intended for grouping and ungrouping a selection of objects.

The Lock and Visible buttons  define the object status. It could be locked for moving and resizing or not. It could also be visible in the preview area or not.

The Schedule buttons  concern project scheduling. The scheduling function allows you to start each object in a project at a specific time/day of week, with specific parameters. You can read more about scheduling in the Scheduler section.

The Schedule window button  opens the scheduler.

The Add to Schedule button  adds the selected object to the schedule.

The Remove from Schedule button  removes the selected object from the schedule list.

The Show Events List button  will open a list of all events, assigned to the currently selected object. See also the Task Manager description.

The Mix Draw Mode button  defines the draw mode of the object. If the button is pushed, two or more overlapping objects will be blended.

(!) TIP: When in Mix object mode, you can switch between the overlapping objects using the <Alt>+ click combination. The name of the currently selected object will appear in the Name field and will be highlighted in the Object list window. You can activate this window from within the Object menu.

The Name field contains the name of the object. The default names are [Type]_[#], i.e. [Crawl 1], [Roll 3], etc. You can change them at your will. The names are most important when you use the Objects list window, where only names and properties are displayed. In order to change the object name, just select the object, and then enter a new name into the Name field.

In the Delay field you can specify a delay for each individual object. A three-second delay means that the object would start three seconds after you have pressed the Show object  button.

In the Duration field you can specify the duration for an object, if needed. The duration determines how long the object will be displayed after pressing the Show object  button.

The Order buttons  allow defining the objects’ order in case they overlap. Overlapping dynamic objects is not desirable.

The Alignment buttons  - allow for aligning objects to each other. These buttons work when more than one object is selected.

The Lock buttons  are used for locking the horizontal or vertical (or both) sizes of the object.

The X and Y numeric fields stand for X and Y positions of the selected object in the 2D space.

The W and H numeric fields stand for Width and Height of the selected object.

NOTE: You cannot change some objects’ size during their running on air.

The Tag  spin-box is used for additional object control. By default, an object’s tag is set to [0]. However, you can enter another value here. The idea of the tag is that you can simultaneously operate with many objects that share the same tag number. This could be done via the script task and the program script task.

 

The 3D Offset spin-box allows you to set an offset to the selected object in terms of depth. If you set a positive number, the object will appear deeper in the screen and vice versa.

The transitions toolbar will help you in setting your objects’ In and Out transition effects:

First, select the transition effect from the In and Out drop-down list. The available types are [Cut(None)], [Cross Fade], [Fly] and [Wipe]. They are not active for Analog clock objects.

In the spin-boxes next to the In/ Out fields set the duration of this transition (by default it is 1.00 second).

NOTE: Increasing the figures in these fields will decrease the speed of the transition.

Finally, define the type of motion during the transition (ascending, descending, or constant). By default, the motion type is set to [0 Normal]. This means that the transition will proceed at constant speed.

For example, if you have set a [Fly From Left] effect and duration of 2 seconds, your object will move at a constant speed from left to right till it reaches the desired position within two seconds. If you set the motion type to [(1 to 5) Ascending], the object will start in a slower motion and its speed will accelerate during the 2 seconds of transition. In descending mode, the speed of the transition will decelerate.

The Full screen transition buttons  are situated next to the transition duration spin-boxes. You might need this functionality in case there are several grouped objects on the screen and these objects have the same transition effect and duration. If you trigger or stop such objects simultaneously, they will move in relation to each-other, because they have to cover different distances on the screen for the same period. Using this button will make objects move together, but not in relation to each-other, during the transitions. The transition of all grouped objects will look as if the entire screen is moving, not the separate objects.

The lowest toolbar contains object-specific settings that change depending on the currently selected object.

If no object is selected, this toolbar allows for changing the work area and the grid.

Push the Token button  if you need to be more precise while drawing the objects in the work area.

You can change the colour of the drawing canvas from the Work Space drop-down palette. To change the colour of the surrounding area, use the Back palette.

The View grid box is checked by default. If you do not want to view the grid dots, uncheck it.

If the Snap to Grid box is checked, all objects in the project will be aligned to the nearest grid point.

If you want to load a picture as a background in the work area, you can browse for it after pressing the  button.

NOTE: Currently, it is not possible to unload the background file, unless you close X-Pert Graphics. You can just change it.

TIP (!)You can take a snapshot of the current output (fill and key) from X-Pert Graphics by pressing<Ctrl+F12>keys on your keyboard. Then, you can paste the shot into a picture editor and save it to a file.